Uploaded image for project: 'LIMS'
  1. LIMS
  2. LIMS-1540

When accent characters are used in a "Sample Type" name, it is not possible to create a new AR.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.6
    • Fix Version/s: 3.1.7
    • Component/s: None
    • Labels:
      None

      Description

      When accent characters are used in a "Sample Type" name, it is not possible to create a new AR. The following error is shown:

      Uncaught TypeError: Cannot read property 'length' of undefinedresourcebika.lims.jsbika.lims.utils.calcs-cachekey-bf6d8a825da2885c4cbeb0e3166d20ec.js:83 (anonymous function)resourcebika.lims.jsthirdpartyjqueryjquery-timepicker-cachekey-9817cb35b3882c097810af1a8c3478a4.js:1240 $.ajax.successresourceplone.app.jquery-cachekey-4a2030ce9039a9082b2f954b73cd6e84.js:12 oresourceplone.app.jquery-cachekey-4a2030ce9039a9082b2f954b73cd6e84.js:12 p.fireWithresourceplone.app.jque

        Activity

        Hide
        lemoene lemoene added a comment -

        Unbelievable... it is the nth time this one rears its head, and every time we think we killed it everywhere. Moving it to the top of the backlog

        Show
        lemoene lemoene added a comment - Unbelievable... it is the nth time this one rears its head, and every time we think we killed it everywhere. Moving it to the top of the backlog
        Hide
        lemoene lemoene added a comment -

        Sorry Pau...-)

        Show
        lemoene lemoene added a comment - Sorry Pau...-)
        Hide
        leonardorojass Leo added a comment -

        I think it is related to last week fix in LIMS-1529

        Show
        leonardorojass Leo added a comment - I think it is related to last week fix in LIMS-1529
        Hide
        Espurna Pau Soliva (Inactive) added a comment -

        I think that it's working.... I attached a demonstration image.

        Have you updated your branches (I think so, just asking...)? I checked it on branch LIMS->hotfix/next and LABSANMARTIN->master.

        Show
        Espurna Pau Soliva (Inactive) added a comment - I think that it's working.... I attached a demonstration image. Have you updated your branches (I think so, just asking...)? I checked it on branch LIMS->hotfix/next and LABSANMARTIN->master.

          People

          • Assignee:
            Espurna Pau Soliva (Inactive)
            Reporter:
            leonardorojass Leo
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile