Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 3.1.7
    • Fix Version/s: 3.1.7
    • Component/s: None
    • Labels:
      None
    • Sprint:
      Jan'15

      Description

      When I try to pass a test, the last modifications on /bika/lims/setupdata/test/test.xlsx give an error.

      The commit is: https://github.com/bikalabs/Bika-LIMS/commit/d56f84b7f39f57b8d63e31de343546845d9b06dc

      I passed the test with the previous test.xlsx

      bin/test -m bika.lims -t test_AnalysisRequestView.robot
      Running bika.lims.testing.BikaTestingLayer:Robot tests:
      Set up plone.testing.zca.LayerCleanup in 0.000 seconds.
      Set up plone.testing.z2.Startup in 0.151 seconds.
      Set up plone.app.testing.layers.PloneFixture in 4.926 seconds.
      Set up bika.lims.testing.BikaTestLayer

      Traceback (most recent call last):
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 366, in run_layer
      setup_layer(options, layer, setup_layers)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 628, in setup_layer
      setup_layer(options, base, setup_layers)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 633, in setup_layer
      layer.setUp()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/plone.app.testing-4.2.2-py2.7.egg/plone/app/testing/helpers.py", line 343, in setUp
      self.setUpPloneSite(portal)
      File "/home/pau/dev/Espurna/bikalims/zinstance/src/bika.lims/bika/lims/testing.py", line 96, in setUpPloneSite
      lsd()
      File "/home/pau/dev/Espurna/bikalims/zinstance/src/bika.lims/bika/lims/exportimport/load_setup_data.py", line 88, in _call_
      assert(workbook is not None)
      AssertionError

      Tearing down left over layers:
      Tear down plone.app.testing.layers.PloneFixture in 0.048 seconds.
      Tear down plone.testing.z2.Startup
      Traceback (most recent call last):
      File "bin/test", line 285, in <module>
      '--test-path', '/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/plone.app.robotframework-0.9.8-py2.7.egg',
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/_init_.py", line 35, in run
      failed = run_internal(defaults, args, script_parts=script_parts)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/_init_.py", line 48, in run_internal
      runner.run()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 138, in run
      self.run_tests()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 242, in run_tests
      tear_down_unneeded(self.options, (), setup_layers, True)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/zope.testing-3.9.7-py2.7.egg/zope/testing/testrunner/runner.py", line 605, in tear_down_unneeded
      l.tearDown()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/plone.testing-4.0.8-py2.7.egg/plone/testing/z2.py", line 308, in tearDown
      self.tearDownBasicProducts()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/plone.testing-4.0.8-py2.7.egg/plone/testing/z2.py", line 605, in tearDownBasicProducts
      with zopeApp() as app:
      File "/home/pau/dev/Espurna/bikalims/Python-2.7/lib/python2.7/contextlib.py", line 17, in _enter_
      return self.gen.next()
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/plone.testing-4.0.8-py2.7.egg/plone/testing/z2.py", line 250, in zopeApp
      app = addRequestContainer(Zope2.app(connection), environ=environ)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/Zope2-2.13.21-py2.7.egg/Zope2/_init_.py", line 52, in app
      return bobo_application(*args, **kw)
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/Zope2-2.13.21-py2.7.egg/App/ZApplication.py", line 75, in _call_
      return connection.root()[aname]
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/ZODB3-3.10.5-py2.7-linux-x86_64.egg/ZODB/Connection.py", line 366, in root
      return RootConvenience(self.get(z64))
      File "/home/pau/dev/Espurna/bikalims/buildout-cache/eggs/ZODB3-3.10.5-py2.7-linux-x86_64.egg/ZODB/Connection.py", line 248, in get
      p, serial = self._storage.load(oid, '')
      AttributeError: 'NoneType' object has no attribute 'load'

        Activity

        Hide
        xispa Jordi (Inactive) added a comment -

        Fixed with https://github.com/bikalabs/Bika-LIMS/pull/1425 I guess. Please Pau Soliva, verify and resolve at will

        Show
        xispa Jordi (Inactive) added a comment - Fixed with https://github.com/bikalabs/Bika-LIMS/pull/1425 I guess. Please Pau Soliva , verify and resolve at will
        Show
        Espurna Pau Soliva (Inactive) added a comment - Fixed in https://github.com/bikalabs/Bika-LIMS/pull/1425

          People

          • Assignee:
            Espurna Pau Soliva (Inactive)
            Reporter:
            Espurna Pau Soliva (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile